FontForge – Unicode point duplicates issue

Primary tabs

1 post / 0 new
Raphael Zwyer's picture
Offline
Joined: 30 Jan 2017 - 9:07am
FontForge – Unicode point duplicates issue
0

Trying to generate a self-created True Type font.

When validating and/or generating the True Type Font I'm getting a bunch of characters with "There is another glyph in the font with this unicode code point" error messages.
This happens after hinting, removing overlaps, correcting directions... It's the only thing that comes up when validating the font, everything else seems to be fine.

Is this a real issue I should be concerned about and if so how do I solve it?
The FF Validation messages don't have any details to them other than the name of the character with the respective issue as quoted above. By clicking on that list item it opens the respective problem character (for example LATIN CAPITAL LETTER E) but I don't see any reference as to where the (other) duplicate character sits and I don't understand what exactly I'm supposed to do.
Am I supposed to just erase that character and hope I killed the right one of the two? Sorry in case I don't see/understand the obvious...

I tried to detach the respective characters. Tried to restart XQuartz and FontForge. But problems/messages persist.

I created the font from scratch. I use my own all Western European Character set (incl. all accents and some ligatures).

XQuartz 2.7.11 (xorg-server 1.18.4) FontForge 18:35 PDT, 2 April 2016 Mac mini (Late 2014), 3GHz i7, 16GB memo macOS Sierra 10.12.2

Any help is appreciated! Thank you!