Custom font family defaulting to Times (except for one typeface)

Primary tabs

4 posts / 0 new
Last post
Jason Aaron Williford's picture
Joined: 4 Mar 2010 - 8:39pm
Custom font family defaulting to Times (except for one typeface)
0

I am using Fontlab to create a font family; there is a regular, bold, and expanded typeface. I have installed the font on a windows machine (not my choice ugh), and it does run properly in MS Word (surprise, note sarcasm). I am only given the Expanded version as an option in MS Word. It defaults to that when I select the font. If I try to manually change it, it gives me Time New Roman, but calls the other fonts Regular, and Bold. It does however run fine in the Adobe Suite, CS2 (what a shock, note sarcasm)

I have examined several MS fonts and I am using the exact settings (with my font names of course) under basic font name panel. I am literally creating the same naming convention and settings for each of the three fonts. Any ideas?

Cristobal Henestrosa's picture
Joined: 24 May 2005 - 7:36am
0
Jason Aaron Williford's picture
Joined: 4 Mar 2010 - 8:39pm
0

Cristobal,

Thanks, your link was helpful. I was able to resolve my problem and I discovered the 99th reason why Microsoft sucks. Office applications aren't interested in anything except regular, bold, italic and bold italic variants. All others are useless to the those applications. Do not get me started on hinting for fonts just so Windoze can display them adequately (if they are going to rip off Mac OS, why not rip off the things that make life easier).

Cristobal Henestrosa's picture
Joined: 24 May 2005 - 7:36am
0

Glad to help. Good luck!